Ciscoパスワードのリセット

イネーブルパスワードを忘れた場合に、パスワードを初期化することができます。

初期化前のrunning-config

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15243DKD-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.1.1.100 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
 password cisco
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

イネーブルパスワードを初期化していきます。

まずは、rommonプロンプトへ移行します。

※rommon(ROM モニタ)は、ルータの電源を投入またはリロードしたときに、ハードウェアを初期化して、Cisco IOS XE ソフトウェアをブートするブートストラップ プログラムのこと

まず、ルータと端末をコンソールケーブルで接続した後で、ルータを再起動し、
直後に、Ctrl + Cを押して、rommonへ移行して下さい。

次に、次回起動時にstartup-configを読み込まないように設定して、ルーターを再起動します。
再起動後、初期セットアップダイアログが表示されたら、noを入力します。

Readonly ROMMON initialized

rommon 1 > confreg 0x2142
rommon 2 > reset
System Bootstrap, Version 15.1(4)M4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 2010 by cisco Systems, Inc.
Total memory size = 512 MB - On-board = 512 MB, DIMM0 = 0 MB
CISCO2901/K9 platform with 524288 Kbytes of main memory
Main memory is configured to 72/-1(On-board/DIMM0) bit mode with ECC disabled

Readonly ROMMON initialized

program load complete, entry point: 0x80803000, size: 0x1b340
program load complete, entry point: 0x80803000, size: 0x1b340

IOS Image Load Test
___________________
Digitally Signed Release Software
program load complete, entry point: 0x81000000, size: 0x3bcd3d8
Self decompressing the image :
########################################################################## [OK]



~~~


         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no

こうすると、工場出荷時の状態でルータが起動してきます。
ルーターの設定は、startup-configに保存してありますので、running-configにコピーします。
その後、イネーブルパスワードを無効化します。

Router#copy startup-config running-config 
Destination filename [running-config]? 

687 bytes copied in 0.416 secs (1651 bytes/sec)
Router#
%SYS-5-CONFIG_I: Configured from console by console

~~~

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no enable secret 
Router(config)#

次に、イネーブルパスワードを無効化した状態のrunning-configをstartup-configへコピーしてから
通常起動するように設定を戻して、ルータを再起動します。

Router#copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration...
[OK]
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#config-register 0x2102
Router(config)#end
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#reload
System configuration has been modified. Save? [yes/no]:yes
Building configuration...
[OK]
Proceed with reload? [confirm]

再起動後のrunning-configを確認すると、イネーブルパスワードが無効化され、その他の設定が残っていることを確認できます。

Current configuration : 648 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO2901/K9 sn FTX15243DKD-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 10.1.1.100 255.255.255.0
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
 password cisco
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

コメント

タイトルとURLをコピーしました